Posts

Showing posts from November, 2009

How to update Linux kernel using YUM

Upgrading a kernel is always a difficult task . If anything goes wrong during the upgrade, the system may become unusable. If you are upgrading the kernel from source , then it needs lots of time and presence of mind while doing the upgrade .  But after yum has come into the picture of package management, upgrading a kernel has become quite easy and that's also in one step .

Using YUM to update the Linux kernel:

Upgrading the Linux kernel using yum is quite easy. yum is intelligent enough in not upgrading the current kernel. Yum installs a newer kernel without upgrading the existing kernel . So , if the new kernel fails to boot up , then you can still use your system by booting from your old kernel . During the upgrade , it also takes care to make entry of the new kernel in /boot/grub/grub.conf  without making any changes to the old entires . So , upgrade your kernel and test it out. Before going with the upgrade , keep a backup of your grub configuration file. The following are t…

YUM Tutorial : Package installer/remover for rpm systems

Evolution of YUM

yum is command line package management utility for Redhat like systems or more specifically Linux distributions which are based on RPM . Before RHEL 5 , rpm used to be package manager in Redhat like systems . But as Linux is becoming popular and more applications are coming in and also more and more people started using it , RPM started showing some limitations . One big issue is that RPM installation fails if the dependencies for a particular package are not installed on the system . Below is an example snippet of installing a package in Linux using RPM.

$ rpm -ivh Download/mplayer-1.0-71_snap20091017.fc11_92.i686.rpm
   warning: Download/mplayer-1.0-71_snap20091017.fc11_92.i686.rpm: Header  

   V4 DSA signature: NOKEY, key ID 66534c2b
    error: Failed dependencies:
    liba52.so.0 is needed by mplayer-4:1.0-71_snap20091017.fc11_92.i686
    libartsc.so.0 is needed by mplayer-4:1.0-71_snap20091017.fc11_92.i686



We can see that the package is dependent on some library …